Lines on top of New Net City monitor and now it’s dead.... Help!

For monitor related issues
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

Hi!

I got my second New Net City a couple of months ago and it has worked great, but has a weird issue when using 31khz systems.
For a minute of two after I turn on my NNC, I get som white lines on top of the image.
They slowly disappear after about 2 minutes, but I guess it something that needs to be addressed sooner or later.
Not notable in 15Khz. Only 31Khz.
Picture is also slightly more “shaky” than my other NNC, but trying to capture this on video was not possible. It’s so subtle that only viewable at close, but something is definitely “off”...
It’s a PD1843 chassis that supposedly was recaped in November 2020, but maybe the seller messed up?

Could this be a cap related issue? Maybe something around the vertical section?

Any tips and or recommendations are most welcome since I have never worked on this type of chassis before.

Added some pictures of the MISTer at boot up since you can see the lines pretty good. Same issues when using Naomi, Type X2, Exa-arcadia etc etc.
2561184E-16EB-43F6-BEE4-2C4EE4F93FB1.jpeg
98FC5463-E2E2-4771-ACB8-66DA8FDC1E2A.jpeg
After about two minutes. All gone.
5262E829-9A84-4683-9537-BDB06ECF718D.jpeg
Last edited by Buddyc on April 8th, 2021, 12:06 am, edited 1 time in total.
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor

Post by Buddyc »

No issues with image quality besides a kind of “shaky” image. Really subtle shaking, but still annoying :awe:
97098347-01ED-44C1-9DA8-D24A5203694A.jpeg
57BAE2A0-076C-4C38-B921-D7DBED4E55D2.jpeg
7C702E03-2451-4976-A821-B05383F187DA.jpeg
User avatar
grantspain
Tech Head
Posts: 4657
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Lines on top of New Net City monitor

Post by grantspain »

if you look around the vertical deflection ic you will see a few caps, these always go bad- replace them and you should be ok but be aware there could be other caps on the chassis, if you inspect most and look underneath at the legs look for any sign of leakage like a green deposit
User avatar
nem
Posts: 2173
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Lines on top of New Net City monitor

Post by nem »

Buddyc wrote:
April 5th, 2021, 8:45 am
It’s a PD1843 chassis that supposedly was recaped in November 2020, but maybe the seller messed up?
Maybe they skipped some or put the 'wrong' caps in.
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor

Post by Buddyc »

Thanks for the advice!

I guess it’s best that I pull the chassis and go into inspection mode.
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor

Post by Buddyc »

Looks like I have all the caps I need to possibly fix this, but a quick follow up question.

Would it be ok to replace a 33uf 16V cap with a 33uf 63V cap?
Same uf. Higher voltage.

Safe or stupid?
User avatar
grantspain
Tech Head
Posts: 4657
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Lines on top of New Net City monitor

Post by grantspain »

yes all good, must consider physical size though to whether it will fit nicely
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor

Post by Buddyc »

Awesome! Thanks again!
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor

Post by Buddyc »

Well.... **** on a stick....

Did the recap and was extra cautious and took my time making sure everything was placed correctly, but now the screen does not power up. I have neck glow and I can hear it start, but no image whatsoever....

Help?
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

I can hear the degauss starting. No fuses blown No caps have bursted. Neck glow is ok and I can hear the yoke is getting power. Looks like the flyback is not starting... crap!

Any tips on where to look?
User avatar
grantspain
Tech Head
Posts: 4657
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by grantspain »

have tried increasing the screen volts on the flyback?
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

grantspain wrote:
April 8th, 2021, 7:30 am
have tried increasing the screen volts on the flyback?
Yes. Nothing happened. It’s like everything turns on, but not the flyback.
It’s strange that I get neck glow, but nothing from the flyback.

Any words of advice?
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

Does anybody know how to measure B+ on a Toshiba PD2367 chassis?
User avatar
grantspain
Tech Head
Posts: 4657
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by grantspain »

how careful were you replacing the caps, you should check every cap you changed for broken tracks

check all fuses including the pico fuse
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

grantspain wrote:
April 8th, 2021, 5:10 pm
how careful were you replacing the caps, you should check every cap you changed for broken tracks

check all fuses including the pico fuse
I was super carful, but I am no expert at all. Seriously don’t trust my own skills right now...
Will pull the chassis out later tonight and take some pictures. Hope I can find the culprit.

Thanks again for the assistance this far Grant. Really appreciate it!
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

Ps. Do you know what the pico fuse looks like and the location?
User avatar
grantspain
Tech Head
Posts: 4657
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by grantspain »

post some photos later and i will point out the pico fuse
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

grantspain wrote:
April 8th, 2021, 7:03 pm
post some photos later and i will point out the pico fuse
9DFDB82C-7652-417D-AB5E-31BEA860DA6D.jpeg
D9BCACC3-51A7-4F5D-807D-C452662C9E20.jpeg
B532FC49-535E-4CD4-A12C-D73A7DF04A7D.jpeg
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

C40314F5-7D44-4F67-835D-990C992ADE97.jpeg
DD6FEB4D-E3D4-412B-A69A-357C7767D551.jpeg
User avatar
Buddyc
Posts: 43
Joined: October 5th, 2019, 1:04 am
Location: Norway
eBay: haver-san
Initials: BAD

Re: Lines on top of New Net City monitor and now it’s dead.... Help!

Post by Buddyc »

250D2F25-A0EB-4CDE-B50E-9EF22F072748.jpeg
FA416F3E-9A16-423D-AB1A-FFD6CE1863D8.jpeg
6AA2FE87-CCCE-46C1-B8BB-AA470930CE97.jpeg
Post Reply