Nanao MS-2930-S 31khz Display issue with Naomi

For monitor related issues
Post Reply
User avatar
hindered
Please Continue...
Posts: 66
Joined: August 26th, 2009, 6:38 pm
Location:

Nanao MS-2930-S 31khz Display issue with Naomi

Post by hindered »

Hi all,

I posted this information in another thread (http://forum.arcadeotaku.com/viewtopic. ... ca#p469590), but in hindsight a: I shouldn't have necro'd/hijacked an old thread, b: I've done enough troubleshooting that it seems clear to me that it's a monitor issue at this point. So, I decided to start a new thread in the Monitor area.

I have a Blast City with a Nanao MS-2390-S manual tri-sync monitor. I also have a handful of game boards (Neo Geo MV-1, Sega ST-V, Naomi) to test with the board. The short version is that 15khz works properly, but 31khz mode does not work. Since the boards and cabinet were all new to me, I wasn't sure 100% that the game boards themselves were good, so I suspected them along with the monitor (which needs a cap kit).

Here's some troubleshooting I did to narrow it down

-----------

Hooked up neo geo motherboard. Monitor on 15khz. Dsub off. Everything works as expected.
Same setup, dsub on. Dim picture as expected - confirmed: dsub dip works.
Neo geo, monitor at 31khz, dsub off. No picture (don't remember if it was scrambled, or black). Confirmed: Flipping dip 2 changes behavior of monitor.

Naomi, 15k, monitor 15k, ran video through sega jvs I/o, dsub off. Everything works.
Naomi, 15k, monitor 15k, ran video to monitor directly, dsub on. Everything works. Confirmed: Naomi can output 15k through I/o and through direct connection (different cables). Cables probably ok.

Naomi 15k, monitor 31k, no sync as expected.
Naomi 31k, monitor 15k, no sync as expected.

Naomi 31k, monitor 31k, still no sync through either the I/o or direct. Picture is super scrambled. The adjustments on the front of the cab do nothing helpful.

For funsies I put the monitor in 24k with the Naomi at 31k. the picture was more legible than when the monitor was at 31k but bad squeal and still no good. Confirmed: monitor can enter three different modes. All dip switches seem to work.

-------------------------

At this point, I rememberd that I had an old low resolution LCD monitor in the basement, so I went and hooked it up to the Naomi in 31khz mode -- success! Confirmed: The Naomi can properly output 31khz VGA.

This means that the problem has to lie with the nanao monitor, right? I actually got around to taking pictures of the display issue as well. I really feel that it's something that should be adjustable via pot but the ones on the front don't help me, and from looking at the manual, none of the ones on the chassis seem likely either (though there are some pots in the manual that aren't labelled, maybe one of those?).
Attachments
Image issue on Nanao monitor
Image issue on Nanao monitor
Image OK on LCD monitor.
Image OK on LCD monitor.
Last edited by hindered on March 4th, 2017, 6:36 pm, edited 1 time in total.
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Sync issue with Naomi

Post by grantspain »

there should be a h.h 31k pot on the main chassis
User avatar
hindered
Please Continue...
Posts: 66
Joined: August 26th, 2009, 6:38 pm
Location:

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by hindered »

Yeah, this one, right? It's got goop on it, so I'll need to cut the goop to adjust it. You think it is a horizontal hold issue?
Attachments
Nanao MS-2930-S adjustment pots
Nanao MS-2930-S adjustment pots
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by grantspain »

well it could be just that adjustment but tbh it looks like its not even syncing to 31khz
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by grantspain »

tbh its more likely to be one of the dil switches is not actually working
User avatar
hindered
Please Continue...
Posts: 66
Joined: August 26th, 2009, 6:38 pm
Location:

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by hindered »

grantspain wrote:tbh its more likely to be one of the dil switches is not actually working
Alright, I'll take them out and meter them to be sure, but I don't feel like that's it. Down/up does 15k like it should, and neither up/down or down/down sync but they fail to sync in different ways, making me think the monitor is entering three different display modes.

Would a video at 31k help diagnose?
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by grantspain »

you do not need to remove the dil switches to meter them-no point in that
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by grantspain »

can post a photo of the remote board set to 31khz-cheers
User avatar
hindered
Please Continue...
Posts: 66
Joined: August 26th, 2009, 6:38 pm
Location:

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by hindered »

grantspain wrote:can post a photo of the remote board set to 31khz-cheers
Sure.
Nanao MS-2930-S 15k DSUB dip settings
Nanao MS-2930-S 15k DSUB dip settings
Nanao MS-2930-S 24k DSUB dip settings
Nanao MS-2930-S 24k DSUB dip settings
Nanao MS-2930-S 31k DSUB dip settings
Nanao MS-2930-S 31k DSUB dip settings
I didn't take a picture of it, but I also did the ON ON ON setup. As expected, it synced to 15k.

I've also got some videos.

Naomi 31k to MS-2930-S 31k: https://www.youtube.com/watch?v=RZiRgI66aS4
Naomi 31k to MS-2930-S 24k: https://www.youtube.com/watch?v=84TrPfRyigQ
Naomi 31k to MS-2930-S 15k: https://www.youtube.com/watch?v=hTIWoSDx2iI
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by grantspain »

i still think it would be wise to meter the dil switches and wiring from the remote
User avatar
hindered
Please Continue...
Posts: 66
Joined: August 26th, 2009, 6:38 pm
Location:

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by hindered »

I took out the remote board and metered the switches -- as expected, all three of them function as expected. I can't really test the wiring because I don't have access to it as the cabinet is still fully assembled.

I don't understand why metering the switches makes sense when I've already demonstrated that flipping the switches causes the monitor to behave differently. Dip switches are either on or off, right? So if they behave differently when on than they do when off, I'd think that proves they work? Same goes for the wiring -- I'd think if flipping a dip causes the monitor to behave differently, the dip and the wiring must be good. If a dip/the wiring was bad, I'd expect flipping the dip to have no affect on the monitor's functionality.

I might be missing something. Please educate me if I am.

I suspect this monitor needs a cap kit in any case, as even at 15k the picture is very pixelated and wavy until it warms up for 5-10 minutes. Is this the kind of issue a cap kit could fix? I'd imagine the 31khz circuitry might not be functioning properly if it has dead/dying caps, but the 15khz could be more or less functional?
User avatar
grantspain
Tech Head
Posts: 4712
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by grantspain »

the first thing you should do is get the chassis out and change the likely caps and check for bad solder joint
namstephan
Please Continue...
Posts: 51
Joined: February 14th, 2017, 2:11 am
Location: Canada

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by namstephan »

Hi, I came across your post as part of research during my restoration of a Blast City with MS-2930 monitor. Just thought I'd share my findings: Using a dreamcast to test the monitor's on-board VGA input (since I don't have any jamma boards yet) I initially got an out of sync picture:

Image

This was seen when dip switches were DOWN DOWN UP which supposedly should give me 31k via D-sub input. Though flicking all three dip switches (I was just messing around at this point) to UP UP UP I managed to get a steady picture:

Image

Not sure why that fixed it, or whether this is helpful to you. Just thought I'd lay out my findings. Best of luck with yours.
User avatar
hindered
Please Continue...
Posts: 66
Joined: August 26th, 2009, 6:38 pm
Location:

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by hindered »

grantspain wrote:the first thing you should do is get the chassis out and change the likely caps and check for bad solder joint
Thanks, grantspain. I'll order a cap kit and get going on this.
namstephan wrote: This was seen when dip switches were DOWN DOWN UP which supposedly should give me 31k via D-sub input. Though flicking all three dip switches (I was just messing around at this point) to UP UP UP I managed to get a steady picture:
This makes me think something is defective with your dip switches -- if the second switch is up, it should be in 15khz regardless of the first switch position. When I test, DOWN UP UP and UP UP UP both behave the same for me -- they sync to 15khz.
namstephan
Please Continue...
Posts: 51
Joined: February 14th, 2017, 2:11 am
Location: Canada

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by namstephan »

hindered wrote: This makes me think something is defective with your dip switches -- if the second switch is up, it should be in 15khz regardless of the first switch position. When I test, DOWN UP UP and UP UP UP both behave the same for me -- they sync to 15khz.
This could very well be the case - upon taking ownership of the cab I was told the monitor "has display issues".

I haven't even tested out 15khz display via Jamma yet - once I get ahold of a board I can find out whether I'm really lucky, or perhaps stuck with 31khz gaming on this monitor. Fingers crossed.
Dave11674
Posts: 4
Joined: July 26th, 2019, 11:35 am
Location: Uk
eBay: 2010JD2010
Initials: DTR

Re: Nanao MS-2930-S 31khz Display issue with Naomi

Post by Dave11674 »

Hi

Did you ever fix this issue ,?

I have a sega blast with exactly the same issue

Dave
Post Reply