Egret 2 / Nanao MS9-29T Ground Issue?

For monitor related issues
Post Reply
kuze
Posts: 84
Joined: September 29th, 2013, 5:09 pm
Location:

Egret 2 / Nanao MS9-29T Ground Issue?

Post by kuze » April 28th, 2019, 12:21 am

Hey guys,

I'm trying to figure out if my Nanao MS9-29T chassis needs servicing, or if I may have a ground issue that is causing video interference.

I've posted a video of the issue here:


It's basically like the geometry warps temporarily intermittently, in some cases like a "wave" or "breathing" motion. But other times it looks perfectly fine.

I did notice that the AC cord coming from the cabinet has no ground pin and it may have been cut or removed at some point.

Is this likely responsible for the issue? Any advice or input on how to best proceed would be greatly appreciated.

User avatar
grantspain
Tech Head
Posts: 4401
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Egret 2 / Nanao MS9-29T Ground Issue?

Post by grantspain » April 28th, 2019, 6:31 am

i would suggest replacing most if not all the electrolytic capacitors, if you still have issues then adjust the ABL pot and check b+
I doubt this is an earth issue

kuze
Posts: 84
Joined: September 29th, 2013, 5:09 pm
Location:

Re: Egret 2 / Nanao MS9-29T Ground Issue?

Post by kuze » April 28th, 2019, 1:54 pm

grantspain wrote:
April 28th, 2019, 6:31 am
i would suggest replacing most if not all the electrolytic capacitors, if you still have issues then adjust the ABL pot and check b+
I doubt this is an earth issue
Thanks Grant, will get it done and report back.

Post Reply