Sony PVM-20L4 Picture Settings

For monitor related issues
User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 2nd, 2016, 2:26 pm

I'm trying to get a decent picture on my monitor but the current settings seem to be way out.

I can get to the engineers service menu by the following button presses:

Menu
Enter + Degauss

Does anyone have any recommended settings they could share with me so I can make a start getting a good picture.

Here's what the picture looks like using a PAL RGB NES

Image

SIG

Level-1
Y Black:
PB Black:
Chroma PB:
Chroma PR
Y Level
CLP P DLY

Level-2
G-Y/B Level:
G-Y/R Level:
PB Level:
PR Level:

White Balance
Sub Contrast:
Sub Bright:
Colour Temp:
Manual/Auto:
Start:
X:
Y:
Ref Value:

Decoder Colour
HP:
CLP:
Burst Gate PLS:
XTAL FO:
Sub Phase:
Acc Phase:
R-Y Phase:

Decoder Level:
Dec Y Level:
Dec B-Y Level:
Dec R-Y Level:
Acc Level:

Deflection:

Focus
H Duty:
HFV Sense:
HFC Control:
H DF Phase:
H DF Para:
Landing:
Last edited by k1ngarth3r on July 2nd, 2016, 3:00 pm, edited 1 time in total.

User avatar
nem
Posts: 1571
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Sony PVM-20L4 Picture Settings

Post by nem » July 2nd, 2016, 2:52 pm

k1ngarth3r wrote:Does anyone have any recommended settings they could share with me so I can make a start getting a good picture.
There are no recommended settings, every monitor (especially since these are old) will be differently set up.

Write down the current settings and start playing around with them. It will be easier if you can a get a test screen up with color bars (240p test suite is super handy for this). If not, your best try it is with a game that is familiar to you.

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 2nd, 2016, 9:18 pm

nem wrote:
k1ngarth3r wrote:Does anyone have any recommended settings they could share with me so I can make a start getting a good picture.
There are no recommended settings, every monitor (especially since these are old) will be differently set up.

Write down the current settings and start playing around with them. It will be easier if you can a get a test screen up with color bars (240p test suite is super handy for this). If not, your best try it is with a game that is familiar to you.
I probably should have worded it better, but the settings seem to be way off so wanted to take someone else's settings to go off and then tweak from there.

I've adjusted quite a few of the settings and go a better picture but this I'll try the 240p test suite somehow cheers.

User avatar
Brettster
Posts: 182
Joined: February 21st, 2015, 10:07 am
Location: Leeds, UK

Re: Sony PVM-20L4 Picture Settings

Post by Brettster » July 3rd, 2016, 9:26 am

Not sure if these are like the 20f1e BVM monitors but they have an "all reset" option to put all the settings to factory settings and start from there
Looking for More Space!

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 3rd, 2016, 7:40 pm

That would be ideal if it has - I will have a look through the service menus to see if I can find the option.

User avatar
skate323k137
Please Continue...
Posts: 91
Joined: October 4th, 2013, 7:37 am
Location: Michigan
eBay: quizknows

Re: Sony PVM-20L4 Picture Settings

Post by skate323k137 » July 3rd, 2016, 7:40 pm

Most have a reset. Also defaults should be listed in the service manuals.

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 4th, 2016, 11:09 am

I can't see the defaults in the service manual :(

Will look for the reset this afternoon.

User avatar
LEGENOARYNINLIA
Still pantless?
Posts: 3206
Joined: March 19th, 2012, 7:22 am
Location: Finland
eBay: jeffrymcmild
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by LEGENOARYNINLIA » July 4th, 2016, 11:48 am

The reset might make things worse.

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 4th, 2016, 11:57 am

You could be right! I will make sure to capture all the settings before pressing it :awe:

RoZioN
Posts: 150
Joined: November 21st, 2011, 12:54 pm
Location: Sweden
Initials: ASH

Re: Sony PVM-20L4 Picture Settings

Post by RoZioN » July 4th, 2016, 1:12 pm

Sorry but have you tried tried the buttons in the front, it looks like the blueonly setting is on or something, or the sync on green is ****? are you sure the RGB is connected correctly?

User avatar
trev1976
Posts: 879
Joined: March 30th, 2009, 7:17 pm
Location: Southampton

Re: Sony PVM-20L4 Picture Settings

Post by trev1976 » July 4th, 2016, 7:32 pm

I need to get me one of these PVM's too ,I'm sure it will go great when sorted
Check out my "1cc" YouTube Channel
YouTube

Reco1210
Posts: 10
Joined: December 15th, 2013, 9:22 am
Location: South Wales
Initials: LEO

Re: Sony PVM-20L4 Picture Settings

Post by Reco1210 » July 14th, 2016, 7:31 pm

Did you get this sorted after? I got the same monitor. I can check my settings and let you know what they are if you want.

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 14th, 2016, 7:37 pm

Well just got some news today in fact...

I ordered an everdrive for the mega drive so I could run 240p test suite (I don't have any consoles with optical drives except the Saturn) which arrived today.

I've performed a factory reset on the PVM and it seems better for sure but the colours don't seem deep still.

I haven't tried Zelda again but will shortly.

I've still got tweaking to do but not sure on which settings to focus the tweaking on tbh.

If you could share your settings that would certainly be helpful just for reference :D

User avatar
Brettster
Posts: 182
Joined: February 21st, 2015, 10:07 am
Location: Leeds, UK

Re: Sony PVM-20L4 Picture Settings

Post by Brettster » July 14th, 2016, 11:48 pm

not so sure on these monitors but you could check that the termination is turned on if it has a switch. the BVM monitor that I had needed 75 Ohm BNC terminators on the output BNC connectors otherwise it looked washed out
the smaller PVM's that I have have automatic termination or external you just slide a switch to enable it

I've also found not all consoles output the same signal strength found the megadrive with resistors in the scart plug to give the nicest most vivid picture
Looking for More Space!

Frankfjs
Posts: 5
Joined: July 9th, 2016, 12:42 pm
Location: Australia

Re: Sony PVM-20L4 Picture Settings

Post by Frankfjs » July 15th, 2016, 12:42 am

Judging by your first pic I'd say that the issue is with a connection/cable problem rather than your monitors settings. Are you using a scart to bnc breakout cable? If so are you sure that it's plugged in correctly/firmly and that there's no broken connection(s)?

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 15th, 2016, 9:39 am

Thanks for the advice guys, I'll check out the suggestions later today / tomorrow.

I'll check the manual to see If I need to manually terminate output but think it does this automatically.

I'll list the cables that I'm using along with the pictures of other systems and how they look later too.

It could be the RGB cable I'm using for my NES - I bought the RGB NES with the cable, all other cables was purchased from https://www.retrogamingcables.co.uk.

Frankfjs
Posts: 5
Joined: July 9th, 2016, 12:42 pm
Location: Australia

Re: Sony PVM-20L4 Picture Settings

Post by Frankfjs » July 15th, 2016, 11:24 am

I bought a pvm cable from the same place and had issues with it. He changed to a new design at some point and the bnc plugs were too large to make a proper connection with the monitor plugs. Does your cable have the big gold bnc plugs? If so it's from the bad batch. With my cable I had to really press the plugs in tight otherwise it wouldn't make a stable connection.

I've since bought a new cable elsewhere.

Gamez
Please Continue...
Posts: 18
Joined: November 12th, 2013, 7:07 pm
Location:

Re: Sony PVM-20L4 Picture Settings

Post by Gamez » July 16th, 2016, 12:06 pm

Maybe your monitor has really been used a lot.

I've tested nearly 100 of these monitors and there are differences between the same models when comparing.

Best way to test would be to connect two together.

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » July 16th, 2016, 6:58 pm

Here's an example of the display I get for some of the system's I have setup.

Currently these are all being manually swapped over to to the PVM via "Female RGBS SCART to BNC adapter cable for Sony PVM/ BVM monitors" from Retro Gaming Cables.

First we have a PAL Mega Drive with Switchless Mod connected with the following cable

Sega Mega Drive Megadrive 1 Genesis 1 audio video AV RGB SCART / JP21 cable TV cord lead
- Output: EuroSCART
- Sync : Composite Video + Sync

Image

Next the PAL NES which has the RGB mod and 3 different colour palette switch

The cable was supplied with the system so don't know who made it.

Image

NB: This is after the factory reset

Next the PAL Sega Master System MK2 with Switchless Mod / RGB mod

The cable also came with the system

Image

Next the NEO-GEO AES US version factory stock

Comes with a cable from Retro Gaming Cables (From 2014) SNK Neo Geo AES stereo sound RGB SCART cable
Item Number AES stereo , SYNC:

Image

I do have other systems but thought this was a good enough example.

I think the picture is pretty good on all now.

The Neo-Geo has always looked sharp to be fair though.

User avatar
k1ngarth3r
Posts: 378
Joined: August 5th, 2011, 4:09 pm
Location: Derbyshire
eBay: t-0-m-t-0-m
Initials: Tom
Contact:

Re: Sony PVM-20L4 Picture Settings

Post by k1ngarth3r » August 13th, 2016, 10:51 am

Just an update...

Today I switched over the PVM to Female scart to a new PVM to male scart to connect to my new switch box.

The colours are now all corrected and look amazing... Previous pictures posted look **** compared.
Last edited by k1ngarth3r on August 13th, 2016, 9:26 pm, edited 1 time in total.

Post Reply