Sanwa PFX / Taito F3 weirdness

For monitor related issues
User avatar
FrancoB
J+ member of the year finalist!
Posts: 4617
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 10th, 2012, 4:23 pm

Hey dude, thanks for that.

Unfortunately that's exactly how I have mine wired too :|

Looks like I'll be trying this diode doohicky thing.

johnnygnct
Posts: 122
Joined: June 12th, 2009, 4:45 pm
Location: Portugal

Re: Sanwa PFX / Taito F3 weirdness

Post by johnnygnct » May 10th, 2012, 4:33 pm

Awkward. I just tried the F3 on my Tosh PF with the exact same connection and no issues! It probably has something to do with some setting on your PFX. Aren't there any pots on the back of the chassis (I haven't messed with mine in a while so I don't really remember)? Maybe you can ask Craig (giz10p)...

User avatar
Rossyra
Supermod
Posts: 8275
Joined: February 12th, 2009, 1:24 am
Location: UK

Re: Sanwa PFX / Taito F3 weirdness

Post by Rossyra » May 10th, 2012, 11:13 pm

Image
Image

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4617
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 11th, 2012, 11:20 am

Ah, thanks for that. The description does indeed sound like what I have.

I guess we are looking at Cure 2. I think there is only positive sync from JAMMA though? Also, It looks like that setup expects there to be a signal going into the vertical sync input where as we are only using H-sync?

Might be worth emailing Craig I think :think:

User avatar
Rossyra
Supermod
Posts: 8275
Joined: February 12th, 2009, 1:24 am
Location: UK

Re: Sanwa PFX / Taito F3 weirdness

Post by Rossyra » May 11th, 2012, 11:39 am

Jamma outputs positive composite sync, so I imagine you'll need the diode on the VGA lead or chassis
Image

User avatar
Hewitson
Posts: 620
Joined: June 4th, 2011, 8:59 am
Location: Melbourne, Australia
Initials: BJA

Re: Sanwa PFX / Taito F3 weirdness

Post by Hewitson » May 12th, 2012, 11:33 am

All JAMMA boards output negative composite sync.
crunchywasp wrote:During your visit you could reverse his evil honey trap and tell him you're a bit uncertain about spending an hour inside his box

User avatar
Rossyra
Supermod
Posts: 8275
Joined: February 12th, 2009, 1:24 am
Location: UK

Re: Sanwa PFX / Taito F3 weirdness

Post by Rossyra » May 12th, 2012, 11:53 am

that's what I meant... er :think: ;) :awe:
Image

Ordyne
Posts: 72
Joined: October 9th, 2008, 9:09 am
Location: Barnsley, South Yorkshire

Re: Sanwa PFX / Taito F3 weirdness

Post by Ordyne » May 15th, 2012, 4:45 pm

If johnnygnct has the same board working on a pfx and you've already checked your video ground there's only going to be 3 main possibilities.

1) Fault on your PFX
2) Fault on your game board
3) Design issue on the PFX sync circuit.

To rule the last one one compare your chassis build to johnnygnct's, theres PFX & PFY if I remember right, then there are different builds of each. Sanwa have in the past added components after production to fix issues, the 29E31S had one but not related to sync. See if johnnygnct can see any added components, he might not want to do this though as they are likely to be on the underside of the chassis.
Craig Walker • Giz10p • http://www.giz10p.co.uk

Specialists In Amusement Equipment Spares & Repairs

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4617
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 15th, 2012, 4:53 pm

Many thanks for that Craig, mucho appreciated :thumbup:

I'll have to see if I can persuade johnnygnct to take some photos of his undercarriage for me :D

johnnygnct
Posts: 122
Joined: June 12th, 2009, 4:45 pm
Location: Portugal

Re: Sanwa PFX / Taito F3 weirdness

Post by johnnygnct » May 18th, 2012, 3:25 pm

FrancoB wrote:Many thanks for that Craig, mucho appreciated :thumbup:

I'll have to see if I can persuade johnnygnct to take some photos of his undercarriage for me :D
Sure thing buddy! As soon as I have the time I'll take some pictures and post them here.

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4617
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 18th, 2012, 3:40 pm

Cheers buddy, thanks 10^6! :)

I'll take some photos of mine in the mean time and post them here too.

Asure
Posts: 570
Joined: April 17th, 2013, 5:16 pm
Location: Netherlands
eBay: asure_nl

Re: Sanwa PFX / Taito F3 weirdness

Post by Asure » September 25th, 2016, 9:10 pm

Rise fwom your gwave..

Got the same thing with mine. Hooked up rgb to the amp connector.
Mvs, works fine. R-type works fine. Oddball midway umk3 and hangtime work fine. But cps2 and cps1 refuse to behave. The image is largely stable but a pulse every second or so distorts the sync.

Did you guys ever resolve this or shall I try some things with a sync cleaner? Anybody with a scope want to tell me the difference in signals between cps2 and mvs? Or is this a super picky monitor?

Asure
Posts: 570
Joined: April 17th, 2013, 5:16 pm
Location: Netherlands
eBay: asure_nl

Re: Sanwa PFX / Taito F3 weirdness

Post by Asure » September 29th, 2016, 8:39 am

Fwiw, this is sorted. Built a LM1881 sync cleaner (added it to one of those jamma-pass-thru adapters w/ voltmeter) and everything is resolved.

User avatar
zak
Posts: 1189
Joined: October 19th, 2014, 1:35 pm
Location: UK
eBay: NA

Re: Sanwa PFX / Taito F3 weirdness

Post by zak » September 29th, 2016, 11:40 am

Asure wrote:Fwiw, this is sorted. Built a LM1881 sync cleaner (added it to one of those jamma-pass-thru adapters w/ voltmeter) and everything is resolved.
That's awesome! :) Do you have a picture?

Asure
Posts: 570
Joined: April 17th, 2013, 5:16 pm
Location: Netherlands
eBay: asure_nl

Re: Sanwa PFX / Taito F3 weirdness

Post by Asure » September 29th, 2016, 2:36 pm

Image

I used ~150K resistor as i had nothing else around, which also seems to work fine.

My passthru looks horrible, but i will take s picture for giggles. Noticed there are some nice little boards around these days. Take a look:
http://retrorgb.com/syncstripper.html

In short, you feed your dirty composite sync into 'composite video' input, and take clean composite sync from the composite sync output on the LM1881. And that goes into the HSYNC input on the Sanwa PFX.

I guess the signals from cps1/cps2 were a little off-spec and the F3 possible as well. (didnt't test F3)
If you have a spare Extron unit around you could try the front "buffer output" connector as well if you use all VGA cabling. (109x). The front 'buffered' output is also cleaned & separated h/v sync.
(This buffer output is clean & also works for MS293x and poor XBOX 360 VGA signals that cause the video to drop off after a few minutes..)

Asure
Posts: 570
Joined: April 17th, 2013, 5:16 pm
Location: Netherlands
eBay: asure_nl

Re: Sanwa PFX / Taito F3 weirdness

Post by Asure » September 30th, 2016, 10:34 pm

zak wrote:That's awesome! :) Do you have a picture?
This is what it looks like. Note, it's the bottom of the pass-thru pcb. (voltmeter is at the top, power on the right.)

https://www.dropbox.com/s/wc8japq1arznd ... 5.jpg?dl=0

Post Reply