Sanwa PFX / Taito F3 weirdness

For monitor related issues
User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 12th, 2011, 10:49 am

My PFX doesn't seem to like my Taito F3 mobo/games. When I put a F3 game in I get this:

Image

It also makes the OSD go funky :eh:

Image

It looks like it could be horizontal hold. There isn't a setting for it in the normal OSD. I entered the service menu and found a 'H MOIRE' setting but that doesn't seem to have any effect.

I have looked in the manual but I can't seem to find anything about horizontal hold in there either.

Any ideas?

I have played the F3 on the MS9 in my NAC and it plays fine. :think:

User avatar
grantspain
Tech Head
Posts: 4476
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Sanwa PFX / Taito F3 weirdness

Post by grantspain » May 12th, 2011, 10:52 am

it's a sync issue-not seen a pfx set to 15k,is it through a 6 pin plug?

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 12th, 2011, 10:56 am

Cheers Grant.

F3 mobo is plugged into a Namco Jamma>JVS which then connected to the PFX with a VGA cable.

I don't know if its worth mentioning but all other 15k games work fine with the above setup.

User avatar
grantspain
Tech Head
Posts: 4476
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Sanwa PFX / Taito F3 weirdness

Post by grantspain » May 12th, 2011, 11:30 am

could be video ground-maybe the f3 takes video ground from pin 1,easy to prove though by linking a the video ground on the d sub connector to pin 1

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 13th, 2011, 9:21 am

What would be the best way to do that Grant?

I tried linking video ground and ground at the Jamma edge but it didn't make any difference.

User avatar
grantspain
Tech Head
Posts: 4476
Joined: August 17th, 2008, 4:23 pm
Location: down south

Re: Sanwa PFX / Taito F3 weirdness

Post by grantspain » May 13th, 2011, 10:26 am

i don't think the vga connector is happy with the sync,in the wiki there are notes about 15khz connection

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 4th, 2012, 9:47 am

I thought it was time to revisit this. Edit: **** me, almost a year :crazy:

I'm no longer using the Namco JVS>JAMMA adapter and I'm now just using a JAMMA loom.

I've sent the video though both of the VGA header and the 8 pin AMP UP video header and I get the same issue using both of them.

Any ideas anyone?

IIRC my Shinobi on System 16B did the same thing. :think:

johnnygnct
Posts: 122
Joined: June 12th, 2009, 4:45 pm
Location: Portugal

Re: Sanwa PFX / Taito F3 weirdness

Post by johnnygnct » May 6th, 2012, 4:42 pm

Franco, my Taito F3 mobo works perfectly with my PFX using a custom loom. No sync issues or anything.

Image

edit: Forgot to say but it's using the vga header.

mariobrothers
Posts: 11
Joined: May 2nd, 2012, 7:56 am
Location:

Re: Sanwa PFX / Taito F3 weirdness

Post by mariobrothers » May 9th, 2012, 8:17 am

hey guys is it the chassy with kw0606a written on it?

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 9th, 2012, 8:33 am

johnnygnct wrote:Franco, my Taito F3 mobo works perfectly with my PFX using a custom loom. No sync issues or anything.

edit: Forgot to say but it's using the vga header.
Hey buddy, I've just seen this.

How did you wire your VGA lead. Did you tie V-sync and H-sync together?
mariobrothers wrote:hey guys is it the chassy with kw0606a written on it?
I'm not sure. I would have to look.

User avatar
KmanSweden
KmanSweden
Posts: 1362
Joined: October 13th, 2010, 10:37 am
Location: Stockholm, Sweden
eBay: KmanSweden
Initials: PKK
Contact:

Re: Sanwa PFX / Taito F3 weirdness

Post by KmanSweden » May 9th, 2012, 8:46 am

I fixed my Carrier Airwing boot that looked like this...
[+] Spoiler...
Image
..in my Astro City but works flawless in my old woody, by doing this..
[+] Spoiler...
Image
eg. jumper wire from VIDEO GND to GND.


EDIT! Oh I see now you've tried this.. My bad..
Up the Irons!

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 9th, 2012, 8:51 am

Cheers dude. I did try that.
FrancoB wrote: I tried linking video ground and ground at the Jamma edge but it didn't make any difference.
I'll might give it another go though just in case.

User avatar
KmanSweden
KmanSweden
Posts: 1362
Joined: October 13th, 2010, 10:37 am
Location: Stockholm, Sweden
eBay: KmanSweden
Initials: PKK
Contact:

Re: Sanwa PFX / Taito F3 weirdness

Post by KmanSweden » May 10th, 2012, 8:39 am

Any luck?
Up the Irons!

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 10th, 2012, 8:48 am

You think I get time to work on my own things? :awe:

I'll take a look over the weekend. I want to hear how johnnygnct wired his video.

User avatar
KmanSweden
KmanSweden
Posts: 1362
Joined: October 13th, 2010, 10:37 am
Location: Stockholm, Sweden
eBay: KmanSweden
Initials: PKK
Contact:

Re: Sanwa PFX / Taito F3 weirdness

Post by KmanSweden » May 10th, 2012, 8:51 am

FrancoB wrote:You think I get time to work on my own things? :awe:
:palm: :lol:
Up the Irons!

User avatar
Rossyra
Supermod
Posts: 8271
Joined: February 12th, 2009, 1:24 am
Location: UK

Re: Sanwa PFX / Taito F3 weirdness

Post by Rossyra » May 10th, 2012, 2:22 pm

So my Gunforce PCB manual has a section on Monitor sync problems, including tearing like that. One of the solutions is to add a fast-switching diode 1n148 iirc to connect H-sync to v-sync.

Might be worth a shot
Image

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 10th, 2012, 3:41 pm

Thanks mah mang, anything is worth a go.

Was it a 1n4148?

User avatar
Rossyra
Supermod
Posts: 8271
Joined: February 12th, 2009, 1:24 am
Location: UK

Re: Sanwa PFX / Taito F3 weirdness

Post by Rossyra » May 10th, 2012, 3:43 pm

I can't remember precisely now :palm:

I'll take a pic of it for ye tonight, so you can see the orientation as well
Image

User avatar
FrancoB
J+ member of the year finalist!
Posts: 4601
Joined: June 8th, 2009, 10:42 pm
Location: Buckinghamshire
eBay: francosquashking
Initials: FRN

Re: Sanwa PFX / Taito F3 weirdness

Post by FrancoB » May 10th, 2012, 3:45 pm

o/\

johnnygnct
Posts: 122
Joined: June 12th, 2009, 4:45 pm
Location: Portugal

Re: Sanwa PFX / Taito F3 weirdness

Post by johnnygnct » May 10th, 2012, 4:16 pm

FrancoB wrote: Hey buddy, I've just seen this.

How did you wire your VGA lead. Did you tie V-sync and H-sync together?
Nop. RGB on pins 1, 2 and 3 (with 220ohm resistors like you did); Gnd on pins 5, 6, 7, 8 and 10; and just H sync on pin 13 (connected to P on the solder side of the jamma connector). No problems whatsover until now. Every pcb I tested works great. I read somewhere that you'd only need H-sync for jamma. HTH

Post Reply