F3 Darksoft help needed

PCB problems and fixes
Post Reply
Stox58
Posts: 15
Joined: July 24th, 2017, 6:30 pm
Location: UK
eBay: Stox58
Initials: LJA

F3 Darksoft help needed

Post by Stox58 »

Hi,

I'm having some trouble getting my F3 Darksoft kit working, my Motherboard is tested working ok with a cart. I'm using a 1GB SanDisk micro SD. I can scroll through the games list on the LCD and it will write to flash and it then tells me the game is loaded, but nothing is showing on the monitor, just showing like there is no cart installed on the motherboard.
Please can someone point me in the right direction.

many thanks from Luke
User avatar
cools
Armed Police Buttrider
Posts: 12758
Joined: August 17th, 2008, 4:49 pm
Location: Wales, United Kingdom
eBay: hordarian
Initials: CLS

Re: F3 Darksoft help needed

Post by cools »

Image
Stox58
Posts: 15
Joined: July 24th, 2017, 6:30 pm
Location: UK
eBay: Stox58
Initials: LJA

Re: F3 Darksoft help needed

Post by Stox58 »

Sorted now, many thanks to Penrhos 28 for his help
User avatar
penrhos
Panel Beater
Posts: 1477
Joined: September 11th, 2008, 12:08 pm
Location: Leicester - UK
eBay: ngpd002

Re: F3 Darksoft help needed

Post by penrhos »

For reference - If you get lines across the display and nothing runs, but the LCD screen shows the cart is loading games try this.

Remove the DS cart from the motherboard,
Check the connectors on the motherboard for bent pins,
Check you removed enough of the region pins so they are flush with the bottom of the connector,
Put an original cart on the motherboard, press the "test" switch when powering it on and do a factory reset.
Re-seat the DS-Multi ensuring that its pushed down as far as it'll go on all four connectors and that it's sitting level and try again.

in this case a squirt of contact cleaner was applied to the pins as they looked a bit tarnished. PSU was running at 5.1V under load from the F3 board.
2 * Vewlix Diamond Blacks,2 * Vewlix-F, 1 * Sega Rally 3, 1 * Video Pinball, 1 * DinoKing (JAMMA Converted).
Post Reply