Irem M92 don't start on Sega Blast City :

PCB problems and fixes
Post Reply
User avatar
Sakuragi
Please Continue...
Posts: 8
Joined: November 21st, 2015, 1:14 am
Location: France

Irem M92 don't start on Sega Blast City :

Post by Sakuragi » December 1st, 2015, 1:04 am

Hello,
I'm the owner of two Irem's M92 Pcbs : In the hunt and Gunforce II, both are Korean. Everything than M92 is working on my Blast City ( many pcbs, MVS, PGM, CPS2 ... ), the weird thing is that In the hunt and Gunforce II are working on my supergun so the games are fonctionnals. I ve tried to compare both jamma connectors but don't find what does the games working. WIth the games plug I have 4,64 v on my Supergun and 4,91 on my Blast, I ve tried to link the video ground on the general ground on the Blast but the games still not start ( no picture or sound, nothing ... ).

here are some pictures of the jamma connectors maybe you will find a clue ?

Supergun
Jamma Super Gun Recto
Jamma Supergun Verso

Blast
Jamma Blast City Recto
Jamma Blast City Verso

Thanks for reading me, hope someone could help me :think:

User avatar
rugdoctor
Posts: 633
Joined: June 23rd, 2010, 5:45 am
Location: New Zealand, Wellington
Initials: KLM
Contact:

Re: Irem M92 don't start on Sega Blast City :

Post by rugdoctor » December 1st, 2015, 2:54 am

The blast city does not have -5V, that might be the problem with older boards.
my website: http://kelvinsgamingheaven.blogspot.co.nz/" onclick="window.open(this.href);return false;

User avatar
copados33
Posts: 472
Joined: March 20th, 2013, 1:30 pm
Location: Uruguay South America
eBay: psycho-q

Re: Irem M92 don't start on Sega Blast City :

Post by copados33 » December 1st, 2015, 3:16 am


User avatar
Sakuragi
Please Continue...
Posts: 8
Joined: November 21st, 2015, 1:14 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by Sakuragi » December 1st, 2015, 4:24 am

Thanks for the replies, I have already tried the - 5v ( a wire between the - 5 v pin of the supergun to the - 5 v of the Blast :angel: ... ) and nothing happens. Doesn't seems to be requiered if refered to the Operator Manual of In the Hunt http://gamesdbase.com/Media/SYSTEM/Arca ... -_Irem.pdf

I will try to unsoldered the - 5 v on the supergun just to be sure.

User avatar
Asayuki
Please Continue...
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Irem M92 don't start on Sega Blast City :

Post by Asayuki » December 1st, 2015, 5:32 am

-5V and +12V are typically only used for analog circuitry. Getting neither video nor audio sounds more like a non booting board.
I would also check if there is any input which is always seen as pressed by the board. If you hold some buttons pressed at boot (expecially service, test or tilt) then some boards won't start at all, indefinitely waiting for the switch to be released before doing anything else.
Back to the -5V thing, the board you photographed has no traces going to the -5 pin, which confirms that voltage to be not required. However, wiring -5V with just one wire from your supergun is not going to work either, unless you share its ground as well ;)
I hope this helps.
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

User avatar
Sakuragi
Please Continue...
Posts: 8
Joined: November 21st, 2015, 1:14 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by Sakuragi » December 1st, 2015, 5:53 am

Nothing is pressed either on the pannel and the pcb when I turn on the Power Supply. Incompatibility with Sanwa buttons ? ( joke :D )

Seems I'm the only one on earth to have a Blast City with M92 :think:

User avatar
Asayuki
Please Continue...
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Irem M92 don't start on Sega Blast City :

Post by Asayuki » December 1st, 2015, 11:09 am

Sakuragi wrote:Nothing is pressed either on the pannel and the pcb when I turn on the Power Supply.
Hmm... I am not sure I conveyed the right message with the word "pressed". I mean "electrically" pressed. That is: check with a multimeter that the pins for all inputs, expecially test, service and tilt, are not stuck low. You should see something like 3.3V or 5V on each pin.
Sakuragi wrote:Incompatibility with Sanwa buttons ? ( joke :D )
LOL :lol:

edit: failing that, you could compare each and every single pin's voltage with what you measure when connected to your supergun. Some measurement will definitely not match, by far; and that's where your issue might be. With that info we can provide more help.
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

User avatar
Sakuragi
Please Continue...
Posts: 8
Joined: November 21st, 2015, 1:14 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by Sakuragi » December 1st, 2015, 12:05 pm

Thanks Asayuki,
I was not aware of this, I'll do a comparison between the supergun and the blast.

I've got an answer from someone who have a Korean Irem M92 with the same problem :
"It's a classical problem with the Korean versions of Irem.

The game will not start if the power supply is fast for reaching nominals voltages. Capacitors are in question. Adding the capacitor missing on the Korean version to be like the Japanese do the trick but not all the time. Irem Korean games needs a "slow" power supply to run perfectly."

User avatar
rugdoctor
Posts: 633
Joined: June 23rd, 2010, 5:45 am
Location: New Zealand, Wellington
Initials: KLM
Contact:

Re: Irem M92 don't start on Sega Blast City :

Post by rugdoctor » December 1st, 2015, 5:59 pm

I think there is a mention of games that will work if you rapidly power cycle a few times. Not the ideal way to play but it was a finicky way to overcome the caps issue.
my website: http://kelvinsgamingheaven.blogspot.co.nz/" onclick="window.open(this.href);return false;

User avatar
Asayuki
Please Continue...
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Irem M92 don't start on Sega Blast City :

Post by Asayuki » December 2nd, 2015, 4:40 am

Sakuragi wrote:"It's a classical problem with the Korean versions of Irem. The game will not start if the power supply is fast for reaching nominals voltages.
I didn't know of this tendency about korean Irem boards. One never stops learning.
The speed with which capacitors charge, and thereby the slope of the corresponding rising voltage, depends on both capacitance and internal parasitic resistance (or ESR) of the capacitor itself. Adding more capacitance will definitely make the slope less and less steep; however, a board which shows this kind of dependency from the slope of the rising voltage rails usually indicates a mistake or a too cheap approach in the design of the reset circuitry. If that is the problem you are experiencing, and you feel you can tackle the task, you could try and find the reset generator (usually a resistor-capacitor combination, at times helped by an 1N4148 or similar diode, which feeds some inverter or other logic gate usually in the area around the main CPU): increasing the capacitance in this circuit is going to require a much smaller capacitor than you would need for the power supply itself, because the series resistance of the circuit is much higher than that of the power supply. In a nutshell, if the reset circuit uses 10uF then 100uF are probably going to do the trick.
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

neocps1
Banned
Posts: 83
Joined: May 5th, 2012, 8:55 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by neocps1 » December 2nd, 2015, 8:36 am

Yep, probably a reset problem due to a bad cap or bad soldering.

But I can't find where is the reset circuit on the motherboard :roll:

User avatar
Asayuki
Please Continue...
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Irem M92 don't start on Sega Blast City :

Post by Asayuki » December 2nd, 2015, 1:35 pm

neocps1 wrote:But I can't find where is the reset circuit on the motherboard :roll:
Check the datasheet of the CPU, find the reset pin and follow the trace. The beeper helps there. Usually the circuitry you are looking for will be nearby. By the way, photo of the board? ;)
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

neocps1
Banned
Posts: 83
Joined: May 5th, 2012, 8:55 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by neocps1 » December 2nd, 2015, 2:13 pm

This is first thing I did.I looked for the cpu datasheet of course but couldn't find one.

I know it seems odd, but I found none

User avatar
Asayuki
Please Continue...
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Irem M92 don't start on Sega Blast City :

Post by Asayuki » December 2nd, 2015, 8:16 pm

http://www.datasheetarchive.com/uPD7013 ... heet.html#

Here there are several 46 pages documents with pinouts. Chexk if your part number matches. ;)
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

neocps1
Banned
Posts: 83
Joined: May 5th, 2012, 8:55 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by neocps1 » December 2nd, 2015, 9:01 pm

thank you ! will let you know about the reset circuit and if we can make a fix

neocps1
Banned
Posts: 83
Joined: May 5th, 2012, 8:55 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by neocps1 » December 6th, 2015, 9:56 am

Ok, found the solution. The reset is handled by a M51953 on the japanese board which is absent on the korean board and replaced by a single 10uF capacitor.

Removing the capacitor and soldering a M51953A or B solves the reset problem :awe:

User avatar
Asayuki
Please Continue...
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Irem M92 don't start on Sega Blast City :

Post by Asayuki » December 6th, 2015, 10:07 am

I'm glad the issue got solved. Happy InTheHunting!:)
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

User avatar
Sakuragi
Please Continue...
Posts: 8
Joined: November 21st, 2015, 1:14 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by Sakuragi » December 7th, 2015, 2:08 pm

Vey good news !
thank you very to you two, I'll check my boards and try this solution :thumbupright:

Asure
Posts: 570
Joined: April 17th, 2013, 5:16 pm
Location: Netherlands
eBay: asure_nl

Re: Irem M92 don't start on Sega Blast City :

Post by Asure » December 7th, 2015, 7:48 pm

An easier solution will be to replace the capacitor with something bigger. Say a 100uF cap has a much longer charging time than a 10uF, so you could try that as well. Plus, it's cheaper :)

neocps1
Banned
Posts: 83
Joined: May 5th, 2012, 8:55 am
Location: France

Re: Irem M92 don't start on Sega Blast City :

Post by neocps1 » December 8th, 2015, 5:12 am

Asure wrote:An easier solution will be to replace the capacitor with something bigger. Say a 100uF cap has a much longer charging time than a 10uF, so you could try that as well. Plus, it's cheaper :)
cheaper but does not work. i tried it first

Post Reply