Naomi 2 - The black death chronicles

PCB problems and fixes
Post Reply
RoZioN
Posts: 150
Joined: November 21st, 2011, 12:54 pm
Location: Sweden
Initials: ASH

Naomi 2 - The black death chronicles

Post by RoZioN » September 17th, 2015, 3:04 pm

So, I have 2x naomi 2 which are both showing a black screen. Im running them in my NNC with stock PSU. My Naomi 1s work perfectly in the cab. The video issue is the same regardless of cart/dimm/bare.

Where do I start? I paid a pretty penny for these and would like to get them going.

The diods on the inside seem to light up and the fans work.

rkrenicki
Posts: 11
Joined: September 2nd, 2015, 12:57 am
Location: Connecticut
eBay: krenfam

Re: Naomi 2 - The black death chronicles

Post by rkrenicki » September 17th, 2015, 6:40 pm

What sort of display are you using? Perhaps a 15/31kHz select issue?

Layer
Posts: 156
Joined: March 6th, 2013, 5:38 pm
Location: France

Re: Naomi 2 - The black death chronicles

Post by Layer » September 18th, 2015, 6:45 am

First, check your 5V is enough (but less than 5.10V).

Black screen :
Check bios is there and good.
Check supercap in C29 has no leak, it may be dead btw.
Check fan CPU work.
Check main RAM work (IC106 & IC107).
CPU issue due to BGA ? Replacing the main RAM can help to boot.

Tyler's Naomi thread issues translated from french : http://www.gamoover.net/Forums/index.ph ... #msg535924

User avatar
leonardoliveira
Posts: 689
Joined: August 30th, 2012, 5:53 am
Location: Brazil
Initials: leo

Re: Naomi 2 - The black death chronicles

Post by leonardoliveira » September 18th, 2015, 5:06 pm

One guy once sent me a Naomi2 for repair. Sadly it had the GPUs broken down by bumping.

You know, physics. The GPUs have heavy heatsink+fan assembly glued to them.

If you mail such a system without filling it with something to stop the fans from giving mechanical stress to the GPU chips, there's a chance the GPU chip is ripped apart from the board due to mechanical bumps.


That's death sentence for the kit because the chips are specific to the Naomi2 board. :mad:
Image

User avatar
Asayuki
Posts: 431
Joined: August 29th, 2015, 10:16 pm
Location: Remuria, Germany

Re: Naomi 2 - The black death chronicles

Post by Asayuki » September 20th, 2015, 2:10 pm

I am not really interested in the post-15kHz era, but ROFL for the super vibration-proof design by Sega!
My 15kHz cabinet Peplos will never power up, with any item, and I am quite proud of that.

mookie3three
Posts: 14
Joined: July 24th, 2013, 6:46 am
Location: Australia
eBay: adoe546

Re: Naomi 2 - The black death chronicles

Post by mookie3three » September 21st, 2015, 3:49 am

A friend of mines Naomi 2 just stopped working out of the blue. It was giving the black screen. The super cap was already removed. I could immediately see that one of the cpu fans wasn't spinning. So I've ordered some replacements and hopefully that is the only issue.

User avatar
leonardoliveira
Posts: 689
Joined: August 30th, 2012, 5:53 am
Location: Brazil
Initials: leo

Re: Naomi 2 - The black death chronicles

Post by leonardoliveira » September 21st, 2015, 5:27 am

Just mentioning, the 2nd revision of the Dreamcast had a protection where it's clock generator chip detected pulses from the fan spinning. If the fan stops spinning it cuts the clock source for the GPU chip after 2 seconds without pulses.

The TV/monitor get no sync signal when that happens (the GPU won't generate any video of course). The point is that without the clock it doesn't heat so it protects the chipset from damage.
Image

RoZioN
Posts: 150
Joined: November 21st, 2011, 12:54 pm
Location: Sweden
Initials: ASH

Re: Naomi 2 - The black death chronicles

Post by RoZioN » September 22nd, 2015, 12:12 pm

Thank you for the tips! I've sent one of the board with a fellow member to try in his cabinet. Ill look at the other things tonight. If I can salvage one working from 2 then I'll be happy.

The whole GPU-fan-thing reminds my of the Hikarusituation. not in a good way.

Thanks again

RoZioN
Posts: 150
Joined: November 21st, 2011, 12:54 pm
Location: Sweden
Initials: ASH

Re: Naomi 2 - The black death chronicles

Post by RoZioN » October 6th, 2015, 7:06 pm

So I tried removing the C29, still no go. both fans are spinning, the main casefan was not so I took one rom a naomi 1 to try and still no go.
anything else I can try? replacing the RAM looks difficult...

Post Reply