Search found 29 matches

by Samelak
November 15th, 2020, 1:57 am
Forum: Cabinet Q&A
Topic: NEO 29 Power Supply Issue & What Style Connectors?
Replies: 1
Views: 190

NEO 29 Power Supply Issue & What Style Connectors?

What style connectors do the NEO Candies use? They are different than my Sega Candies. My power supply is acting up and I hope I can rebuild it. In case I can’t, I want to adapt the harness to a generic arcade power supply. Also need a source if you have one. ...and if anyone has any ideas for my po...
by Samelak
October 12th, 2020, 9:33 am
Forum: Monitor Q&A
Topic: Blurry Monitor Issue
Replies: 6
Views: 507

Re: Blurry Monitor Issue

Are you talking on the remote adjustment board?
by Samelak
October 12th, 2020, 9:13 am
Forum: Monitor Q&A
Topic: Blurry Monitor Issue
Replies: 6
Views: 507

Re: Blurry Monitor Issue

I had a chance to pull the monitor today. I used contact cleaner on the CRT socket and the neck pins. Plus reseated all of the connections on the chassis several times. Still a blurry picture until warms up. So I adjusted the flyback and noticed that I needed to crank the focus all the way over to g...
by Samelak
September 22nd, 2020, 12:05 pm
Forum: Monitor Q&A
Topic: Blurry Monitor Issue
Replies: 6
Views: 507

Blurry Monitor Issue

I am fairly sure the issue is with the cabinet, but I am experiencing problems with the monitor picture. This is a Sega Blast City that I had a 2931 NANAO in. When I turn on the cabinet, I get a really blurry picture (sometimes extremely bad) but after 20 minutes, the pictures comes into better (not...
by Samelak
August 22nd, 2020, 12:32 pm
Forum: Game Hardware Q&A
Topic: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)
Replies: 592
Views: 130535

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

I need someone who can take a look at my Darksoft Kit. I was getting bad sound coming out and tried reseating the main board from the kit. Plugged it back in and now there is no picture. Pulled it off and noticed some of the long pins are now broken. I tried solder tips on, but still no good. Anyone...
by Samelak
March 22nd, 2020, 7:32 pm
Forum: Cabinet Q&A
Topic: Blast City with Blurry Screen For About 5 Minutes
Replies: 2
Views: 462

Re: Blast City with Blurry Screen For About 5 Minutes

Tried reflowing with new solder. Personally I don't think its just regular solder they used on it. I've done a lot soldering on a variety of PCBs and never had such trouble getting components out.
by Samelak
March 22nd, 2020, 5:49 am
Forum: Cabinet Q&A
Topic: Blast City with Blurry Screen For About 5 Minutes
Replies: 2
Views: 462

Blast City with Blurry Screen For About 5 Minutes

I've been trying to figure out why my Blast City has a blurry screen after powering up. I've tried a NANAO 2930 monitor and MS-9 monitor with similar results. I thought it might be the harness connections at the I/O board, but I swapped in a spare harness with the same results. I don't have a spare ...
by Samelak
December 29th, 2019, 12:08 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

So can it be used in a regular Blast without modification?
by Samelak
December 28th, 2019, 11:22 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

I recapped the PSU with the 220v sticker on it and plugged it into the cab. Putting out the correct 120v to the monitor and 5v for the PCB. Unfortunately the 5v pot has a broken center leg. Does anyone have a part number for it (maybe thru Mouser)?
by Samelak
December 21st, 2019, 10:37 pm
Forum: Monitor Q&A
Topic: 29" NANAO 2931 Tube Heater Short - What Happened?
Replies: 8
Views: 1603

Re: 29" NANAO 2931 Tube Heater Short - What Happened?

I'm not gonna lie, I understood very little of that. Can someone point me to a specific component to test?
by Samelak
December 17th, 2019, 5:31 am
Forum: Monitor Q&A
Topic: 29" NANAO 2931 Tube Heater Short - What Happened?
Replies: 8
Views: 1603

Re: 29" NANAO 2931 Tube Heater Short - What Happened?

My first tube that went also had the glass crack in the neck. What is the SMD cap? Plus, my chassis was recapped.
by Samelak
December 16th, 2019, 2:30 pm
Forum: Monitor Q&A
Topic: 29" NANAO 2931 Tube Heater Short - What Happened?
Replies: 8
Views: 1603

29" NANAO 2931 Tube Heater Short - What Happened?

This is actually the 2nd tube that has done this. My replacement tube for my Blast City 2931 recently got a heater short. All I did was power up the cabinet and I heard loud crackling and I shut it down. I thought it might be a dirty anode cup that was arcing because this was an issue with the monit...
by Samelak
December 12th, 2019, 3:56 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

Looking at another post on the forums, its apparently for Limbergh use. Does anyone know if this PSU is limited to that or should it also power JAMMA as well? I would still think my monitor would power on, but I get nothing.
by Samelak
December 12th, 2019, 3:30 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

I found a "grungy" data label and sure enough it said input 100v. I'll plug it in and check voltages. It's still going to need a good clean and re-cap plus new cooling fan. Thanks for the help....now if only I can figure out what's the other PSU. Obviously for a Blast, but what application and can i...
by Samelak
December 10th, 2019, 4:49 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

Here is a picture of the other PSU I have.

Image
by Samelak
December 10th, 2019, 3:42 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

So despite a big red sticker that says 220v on the back side, you are saying internally I am all set to use as is? Can you link in a picture of a 220v PSU for comparison?
by Samelak
December 9th, 2019, 3:31 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Re: Questions on Two Separate Blast City PSUs

The 220V PSUs should have external stepdowns. You won't do any damage if you try to plug a 220V PSU to a 120V outlet. It will either work, or it won't. It should work though. No idea what that PSU in the pic is. Can you take a shot of the front? The back is where fan is. Are you saying the 220 can ...
by Samelak
December 8th, 2019, 7:51 am
Forum: Cabinet Q&A
Topic: Questions on Two Separate Blast City PSUs
Replies: 14
Views: 1948

Questions on Two Separate Blast City PSUs

First question: I finally received a power supply (3 months) from Yanton and it has a big red 220V sticker on it. I don't recall the ad mentioning it being 220V or in the picture. The ad disappeared so I can't verify, but I'm fairly positive I would have noticed. Regardless, I'm upset that I waited ...
by Samelak
July 31st, 2019, 1:07 am
Forum: Cabinet Q&A
Topic: Blast City PSU recap necessary?
Replies: 3
Views: 794

Re: Blast City PSU recap necessary?

If you have never taken apart your PSU, I'd recommend doing so. The amount of dust will both amaze and disgust you. I recapped mine and changed the fan while in there. Super easy job to do.
by Samelak
April 3rd, 2019, 4:23 am
Forum: Game Hardware Q&A
Topic: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)
Replies: 592
Views: 130535

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

I hope I don't catch any crap resurrecting this thread, but I'm not finding the answers I need. So I got my Darksoft kit and it's installed on a revision 7 board with a G PAL. I'm using a 4GB card with Avalaunch files. Here are the problems I am having: 1. The Avalaunch files didn't have the D&D gam...