Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

PCB problems and fixes
Forum rules
ArcadeOtaku forum introduction & rules
glossectomy
Posts: 12
Joined: June 8th, 2015, 2:04 am
Aliases: Baphomet
eBay: Glossectomy666
Gamertag: Retrodoneright
PSN: SigilBaphomet
Initials: 666
Location: Denver

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby glossectomy » August 19th, 2015, 12:11 am

funkycochise wrote:Due to some request, here is SSF2X training version (by Jed Possum) converted to MultiCPS2 format :
https://mega.co.nz/#!WRBRUKJI!zoKnM2oXp47zMtinLSwLmA09r0FeYEY6EM5DXttEZkY


I'm having issues getting this to work. Is there anything I should be doing?
Kagaden
Posts: 1
Joined: August 23rd, 2015, 6:30 pm
Location: LA, CA

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby Kagaden » August 23rd, 2015, 6:34 pm

I've received my kit and am looking to purchase a cps2 rev. 5, 6, or 7 PCB.

Are there certain games I should look for? :awe:

Thanks!
User avatar
wigsplitta
Savile's alibi
Posts: 1083
Joined: December 11th, 2008, 11:38 am
Location: Fareham / Crawley

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby wigsplitta » September 1st, 2015, 7:54 pm

Finally got my board operational again :awe:

Quick recap on timeline, issue, and resolution FYI:

Rev 6 board, G Pal
Received CPS2 Multi, removed roms, plugged CPS2 Multi - all worked fine
Re-seated multi several times due to the crackling audio. Didn't resolve the crackling, but all still working fine.
Got the reinforcement boards - removed CPS2 Multi, applied, re-seated, all still working fine.
FrancoB kindly lent me his kit to upgrade the firmware for auto reset.
Removed CPS2 multi, upgraded firmware successfully, re-seated - sound suddenly garbled.
Re-seated and played about with seating at least 20 times, did the leg lifting, wire connection for the G Pal, even though it shouldn't need it - no change. Still garbled sound.
Visually inspected all jumpers (don't have a multi-meter to properly check) all looked good.
Decided to cut all open jumpers, just in case they had somehow re-bridged
Re-seated CPS2 Multi - all working good again.

For me - the garbled sound issue was definitely an open jumper that had worked fine for weeks, but then decided to somehow re-bridge. Shame I didn't have any testing kit to pinpoint which jumper(s) were the cause.

Bloodhokuto - how is your board performing with the case causing an issue when put on? I'm wondering if possibly it's a similar issue - an open jumper that has such a fine clearance, that when a bit of pressure is applied, it causes the board to bend very very slightly, but enough to bridge a gap on one of them?
I Got PAID...
ウィッグスプリッター - スーパーガレージゲームセンター。
User avatar
bloodhokuto
Posts: 626
Joined: June 24th, 2012, 4:20 pm
eBay: coryoon
Location: Kent

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby bloodhokuto » September 1st, 2015, 11:29 pm

wigsplitta wrote:
Bloodhokuto - how is your board performing with the case causing an issue when put on? I'm wondering if possibly it's a similar issue - an open jumper that has such a fine clearance, that when a bit of pressure is applied, it causes the board to bend very very slightly, but enough to bridge a gap on one of them?


I was wondering how you were getting on. Nice one on your result!

Have to admit that I have taken a slight hiatus with fiddling with mine, I had thought about jumpers (because I did a few myself and I'm a **** with a soldering iron / desolder pump). But I didn't take into consideration the pcbs flexing.

You post therefore makes me think that you might be onto something! I do have a multimeter, but I might do what you did and just make sure that the open connections that I desoldered are properly isolated (this way also ensures that I don't set fire to the board) :awe:
- -
Looking to get a replacement foot panel for my Minicute.
If anyone sees one, let me know!
- -
Image
darksoft
Posts: 123
Joined: July 8th, 2011, 10:04 pm
eBay: greenberetfan
Initials: PFG
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby darksoft » September 4th, 2015, 6:53 pm

OK. So I can confirm now that the problem of the crackling has been identified and is coming from Chip U40 located at the upper-center part of the Main PCB.

The 74LVC4245 used there are too fast for the bad power quality coming from the B Board. This makes that the chip reacts to small current fluctuations and creates clashes in the data bus.

The only solution that can be applied is changing the U40 for a new tiny custom PCB that I'm going to order today.

Once I receive them, they'lll be tested by me, Mitsu and others so we can confirm 100% it's working.

Once this is confirmed to work, Everyone who wants one replacement will get it completely for free. You should contact Darksoft for any location Worldwide except USA + Canada or contact Mitsurugi if you are based in USA or Canada.

As you can see by the size of U40, this is a tiny work not suitable for everybody ( check position and size of U40 to make sure that you can replace that)

You can source someone local to do the soldering or send it to us for a replace. You'll need to pay return shipping if you want us to replace it.

All kits from now on will already have the update installed.

I'll keep you updated.
Arcade Project Master at www.arcade-projects.com
dreday12203
Posts: 4
Joined: July 21st, 2015, 10:34 pm
Aliases: dreday12203
eBay: its_guaranteed_authentic
Gamertag: ps4 nemesis
PSN: xbox_nemesis
Initials: DRE
Location: Viera, Florida

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby dreday12203 » September 4th, 2015, 7:46 pm

Wow that's great news.
"Key to life is to always remain humble"- Radrea
User avatar
monouchi
Posts: 1015
Joined: February 21st, 2010, 6:16 pm
eBay: monouchi_jn
Initials: BUS
Location: Sweden

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby monouchi » September 5th, 2015, 3:39 am

Argh, sending it out again?
Oh well.... :)
User avatar
wigsplitta
Savile's alibi
Posts: 1083
Joined: December 11th, 2008, 11:38 am
Location: Fareham / Crawley

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby wigsplitta » September 5th, 2015, 1:25 pm

I am happy to confirm that I successfully went for the 8 wire fix :awe:

**** knows how it's possible to do it with individual wires...just too damn tiny for my shaky hands! I dug out and old IDE ribbon cable, and it was almost spot on with the spacing. It kept all the wires nicely together. Taped to the board, spaced, then soldered. I'm pretty damn surprised it worked tbh - you'd all laugh/cry if you saw the soldering iron I'm using.

Its a little 'rough round the edges' but my skills are not up to the task of making it look good.

It works, and that's all that matters to me, especially as I've spent the last few months get multiple qsound and normal amps setup in my cabs, to make the most of all boards that have stereo sound.

Image

Thanks to all involved for getting this issue resolved. Love y'all :fastlove:

(FYI It didn't work first time - a wire or two might've been bridged or not connected, and the result was the corrupt graphics below)
Spoiler: show
Image
I Got PAID...
ウィッグスプリッター - スーパーガレージゲームセンター。
User avatar
leonardoliveira
Posts: 514
Joined: August 30th, 2012, 5:53 am
Initials: leo
Location: Brazil

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby leonardoliveira » September 5th, 2015, 10:58 pm

This is my take at this fix:
Image

The wire used:
https://en.wikipedia.org/wiki/Magnet_wire
Image
User avatar
bloodhokuto
Posts: 626
Joined: June 24th, 2012, 4:20 pm
eBay: coryoon
Location: Kent

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby bloodhokuto » September 6th, 2015, 6:02 pm

Welp.

I checked continuity on the jumpers - all fine, but Ive gone backwards now with this.

The best I managed today was to get he picture working ok with garbled sound, then I adjusted it again and now am back to just having junk on the screen.

Perhaps I shouldn't have touched it when it was running careless but ok, but I'm sure I am not doing anything drastically wrong than everyone else, so why does it just not work, when all the pins are in nice?
- -
Looking to get a replacement foot panel for my Minicute.
If anyone sees one, let me know!
- -
Image
User avatar
MitsurugiW
Posts: 150
Joined: September 19th, 2012, 10:49 pm
eBay: mitsurugi-w
Initials: JBW
Location: New Bern, NC
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby MitsurugiW » September 6th, 2015, 6:10 pm

bloodhokuto wrote:Welp.

I checked continuity on the jumpers - all fine, but Ive gone backwards now with this.

The best I managed today was to get he picture working ok with garbled sound, then I adjusted it again and now am back to just having junk on the screen.

Perhaps I shouldn't have touched it when it was running careless but ok, but I'm sure I am not doing anything drastically wrong than everyone else, so why does it just not work, when all the pins are in nice?



Can you take some high res pics of the pcb itself?
User avatar
bloodhokuto
Posts: 626
Joined: June 24th, 2012, 4:20 pm
eBay: coryoon
Location: Kent

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby bloodhokuto » September 6th, 2015, 6:41 pm

MitsurugiW wrote:

Can you take some high res pics of the pcb itself?


As it is, with everything connected up?

Update:

I have just got it intermittently working, which is pretty much how it was from since before.

Its seems to be a connection issue, but with everything seemingly in firmly I am not sure why that would be except for perhaps dirty contacts with the pins, although I did clean all the contacts when I stripped the original chips from the board.

I have taken some pics, in the album below, showing everything connected, and i know that they may not be much use, but for the time being I am having to keep it in situ while it is actually working. -As soon as I attempt to do anything with it, like plugging/unplugging the lead for the display etc I have to fiddle with it again, so I don't stand a chance of trying to fit it in the case.

Bear in mind this is exactly how it was with my progear board and I thought that there may be some issue with that one.

There can't be the same problem with both B Boards - could there be an actual issue with the multi board itself?

http://s62.photobucket.com/user/CHAOS_S ... lti_issues
- -
Looking to get a replacement foot panel for my Minicute.
If anyone sees one, let me know!
- -
Image
darksoft
Posts: 123
Joined: July 8th, 2011, 10:04 pm
eBay: greenberetfan
Initials: PFG
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby darksoft » October 20th, 2015, 9:08 pm

We have now everything ready to provide the CRACKLE FIX to all those users who want to have it.

There are several options to fix the crackling problem as you can see here:

http://forums.arcade-museum.com/showthr ... ost3177729

The last picture in Mr. Jamma's post shows the mini PCB fix that we have done. This PCB will fix also the crackling issues.

As we have posted here:
http://www.arcade-projects.com/forums/i ... ackle-fix/

We'll fix everyone's kit one way or another. Notice that the crackling can be noticed or not depending if you are running it on a cabinet or on a Supergun.
PM or mail me if you are based in Europe. If you are in USA then PM Mitsu. If you are somewhere else, then you can decide wither one to get your kit updated. You'll need to send us the main PCB of the kit.

We'll post a video soon about how the installation is done.
Arcade Project Master at www.arcade-projects.com
User avatar
MitsurugiW
Posts: 150
Joined: September 19th, 2012, 10:49 pm
eBay: mitsurugi-w
Initials: JBW
Location: New Bern, NC
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby MitsurugiW » October 20th, 2015, 9:36 pm

You can also choose the do the fix yourself and we can just send the fix pcb to you. You do it yourself at your own risk. If you break something while trying to do the fix yourself then we are not responsible. If you are unsure then arrange for one of us to do it for you.
darksoft
Posts: 123
Joined: July 8th, 2011, 10:04 pm
eBay: greenberetfan
Initials: PFG
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby darksoft » October 21st, 2015, 9:22 am

Video about how to apply the fix. Thanks for Mitsurugi-w

https://youtu.be/TYbw-RjR53A

I repeat it again: We'll fix everyone's kit one way or another.

Notice that the crackling can be noticed or not depending if you are running it on a cabinet or on a Supergun.
PM or mail me if you are based in Europe. If you are in USA then PM Mitsu. If you are somewhere else, then you can decide wither one to get your kit updated. You'll need to send us the main PCB of the kit.
Arcade Project Master at www.arcade-projects.com
User avatar
MitsurugiW
Posts: 150
Joined: September 19th, 2012, 10:49 pm
eBay: mitsurugi-w
Initials: JBW
Location: New Bern, NC
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby MitsurugiW » October 21st, 2015, 9:31 am

Assist. (amateur....) :P

darksoft
Posts: 123
Joined: July 8th, 2011, 10:04 pm
eBay: greenberetfan
Initials: PFG
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby darksoft » October 21st, 2015, 9:47 pm

Amateur? You want me to ban you from my forum or what? :)
Arcade Project Master at www.arcade-projects.com
User avatar
leonardoliveira
Posts: 514
Joined: August 30th, 2012, 5:53 am
Initials: leo
Location: Brazil

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby leonardoliveira » October 24th, 2015, 3:00 pm

I really lol'd with the sound bits at the start of the video. :awe:
Image
User avatar
MitsurugiW
Posts: 150
Joined: September 19th, 2012, 10:49 pm
eBay: mitsurugi-w
Initials: JBW
Location: New Bern, NC
Contact:

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby MitsurugiW » October 24th, 2015, 6:17 pm

leonardoliveira wrote:I really lol'd with the sound bits at the start of the video. :awe:


I was waiting for someone too f'cking notice that!! lol

You are a sharp one, Leo. ;)
User avatar
kazuo
Posts: 360
Joined: November 3rd, 2008, 7:18 am
Location: Phuket

Re: Darksoft's CPS2 Multikit Tech Support Thread (No Killing B-Boards!)

Postby kazuo » October 24th, 2015, 6:35 pm

What's a good email to reach you guys to arrange for the sound fix to be done? I have a couple of the kits I'd like this to be sorted out on.

Return to “Game Hardware Q&A”



Who is online

Users browsing this forum: No registered users