Asura Blade & Sengoku Blade - No audio on supergun

PCB problems and fixes
Forum rules
ArcadeOtaku forum introduction & rules
User avatar
KmanSweden
KmanSweden
Posts: 1600
Joined: October 13th, 2010, 10:37 am
Aliases: P373R, Kman-Sweden, Kman_Sweden
eBay: KmanSweden
Gamertag: KmanSweden
Initials: PKK
Location: Stockholm, Sweden
Contact:

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby KmanSweden » February 26th, 2013, 11:32 am

Image
What's up with these boards? :eh:
Up the Irons!
User avatar
Hewitson
Posts: 680
Joined: June 4th, 2011, 8:59 am
Initials: BJA
Location: Melbourne, Australia

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby Hewitson » February 26th, 2013, 12:50 pm

emphatic wrote:IIRC, I've read somewhere that the ordinary GND is better (more compatible) to use for superguns than Speaker-, however I have no written documentation to back this up.

Never use the speaker - as a ground. Many arcade boards use what is known as a complementary symmetry amplifier which means speaker - is speaker + inverted, not ground.

Look at this example from the HA13001 used in the Neo Geo and many others. You will see there is an amplifier connected to BOTH speaker terminals.

Image
crunchywasp wrote:During your visit you could reverse his evil honey trap and tell him you're a bit uncertain about spending an hour inside his box
dbstallman
Posts: 33
Joined: October 31st, 2012, 4:49 pm

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby dbstallman » February 26th, 2013, 7:18 pm

meijin wrote:
crunchywasp wrote:can you confirm please? Cheers :)


I just took a photo of the Asura Blade pcb before I went to work this morning. There is a trace, but it goes to nowhere... :think:


No.... It goes to a via and then pops up on the component side of the board. You need to turn the board over and then follow the trace from there.

You will probably find that it goes to an amp just like the trace on the Sengoku Ace board does.

Brian.
User avatar
Shou
Posts: 481
Joined: August 25th, 2009, 4:45 am
Gamertag: ShouTime
PSN: ItsShouTime
Initials: SHO
Location: Central Tokyo, Japan, Asia, Earth, Solar System, Milky Way
Contact:

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby Shou » February 27th, 2013, 10:44 am

Asura Blade is known to have the audio and audio ground mixed up from the factory. You'll need to swap the wiring for it to work.

Not sure why you have an issue with Sengoku Blade.
User avatar
meijin
Posts: 524
Joined: March 23rd, 2012, 12:47 pm
Location: Munich, Germany

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby meijin » February 27th, 2013, 1:20 pm

Asura Blade is known to have the audio and audio ground mixed up from the factory. You'll need to swap the wiring for it to work.


:think:
If so, then it shouldn't run correctly in a cab, correct? I don't know, but Asura Blade runs without problems in my Aero/Blast (standard Jamma connector) :eh:
User avatar
crunchywasp
stompin' an' jumpin'
Posts: 8980
Joined: February 10th, 2012, 2:51 pm
eBay: crunchywasp
Gamertag: crunchywasp
PSN: crunchywasp
Initials: MAK
Location: Fife, Scotland

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby crunchywasp » February 27th, 2013, 2:20 pm

:think:

Presumably pin L is hooked up on both cabs?
Image
User avatar
meijin
Posts: 524
Joined: March 23rd, 2012, 12:47 pm
Location: Munich, Germany

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby meijin » February 27th, 2013, 2:32 pm

um, I'm not sure at the moment. Let me check it when I'm home ;)
User avatar
crunchywasp
stompin' an' jumpin'
Posts: 8980
Joined: February 10th, 2012, 2:51 pm
eBay: crunchywasp
Gamertag: crunchywasp
PSN: crunchywasp
Initials: MAK
Location: Fife, Scotland

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby crunchywasp » February 27th, 2013, 2:38 pm

Cheers Bastian 8-)
Image
User avatar
Rossyra
Supermod
Posts: 9319
Joined: February 12th, 2009, 1:24 am
Location: UK
Contact:

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby Rossyra » February 27th, 2013, 7:56 pm

meijin wrote:
crunchywasp wrote:can you confirm please? Cheers :)


I just took a photo of the Asura Blade pcb before I went to work this morning. There is a trace, but it goes to nowhere... :think:

Image


Here is also the photo of the Sengoku Blade pcb (solder side).
http://img692.imageshack.us/img692/2341/dscf2847i.jpg


Pin 10 is running to a through-hole in that pic. The key counts as a pin, you're looking at pin 11 (if you're forgetting to include the key) which should normally have no connection for standard Jamma.
Image
User avatar
meijin
Posts: 524
Joined: March 23rd, 2012, 12:47 pm
Location: Munich, Germany

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby meijin » February 27th, 2013, 8:58 pm

crunchywasp wrote::think:

Presumably pin L is hooked up on both cabs?


It is hooked up on both cabs :)

Aero
Image

Blast
Image
User avatar
crunchywasp
stompin' an' jumpin'
Posts: 8980
Joined: February 10th, 2012, 2:51 pm
eBay: crunchywasp
Gamertag: crunchywasp
PSN: crunchywasp
Initials: MAK
Location: Fife, Scotland

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby crunchywasp » February 27th, 2013, 9:49 pm

Thanks for confirming :thumbup: :)

I know pretty much nothing about speakers :( Does wiring them up with the polarity reversed cause any major issues? Would the speaker just operate in reverse or something? :oops:

As far as the cabs are concerned where speaker + (10) at the JAMMA edge is ultimately hooked up to the + post of the speakers and speaker - (L) to the - post of the speakers then all's well and good...

If reversing the polarity of the speakers is ok, although perhaps not ideal, then if speaker + and - were reversed on the PCB for whatever reason then I'm assuming audio would still work ok?
Image
User avatar
emphatic
Breastfeeds when required
Posts: 6956
Joined: April 7th, 2009, 4:14 pm
Aliases: emphatic everywhere, baby!
eBay: jorgen_sjolander
Gamertag: emphatic001
Initials: JOR
Location: Alingsås, Sweden
Contact:

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby emphatic » February 27th, 2013, 10:39 pm

crunchywasp wrote:Thanks for confirming :thumbup: :)

I know pretty much nothing about speakers :( Does wiring them up with the polarity reversed cause any major issues? Would the speaker just operate in reverse or something? :oops:



http://www.ehow.com/info_8372487_happen ... wires.html

Basically, if these games have these pins in reverse, wiring with - and + hooked up to - and + will give sound, even if it's not correct sound. However, if the - is hooked up to GND, well, then the wrongfully hooked up + will go to GND and the - will go to + = no sound.

I think this is the solution, basically.
User avatar
crunchywasp
stompin' an' jumpin'
Posts: 8980
Joined: February 10th, 2012, 2:51 pm
eBay: crunchywasp
Gamertag: crunchywasp
PSN: crunchywasp
Initials: MAK
Location: Fife, Scotland

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby crunchywasp » February 27th, 2013, 11:20 pm

:awe:

Thanks emph.

So where the SG with audio via scart to TV speakers is concerned, specifically for boards where speaker + & - are reversed, am I correct in stating that the following must be true in order for audio to function :

• Pin 10 should be GND

• Pin L should be speaker +

...and in the case of these boards where the cabs are concerned :

• Pin 10 should be speaker -

• Pin L should be speaker +

But although the polarity is reversed the audio still works in the cabs, although with errors.

So a switch or pass-through specifically for use with these boards on the SG would be the easiest solution... :think:
Image
User avatar
julius blaze
Posts: 192
Joined: February 20th, 2009, 9:16 am
eBay: pincer_attack
Location: WA, USA
Contact:

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby julius blaze » March 9th, 2013, 4:49 am

Just throwing it out there, I've seen power supplies with bad -5v that still have working +5 and +12, so maybe measure if you're actually getting -5 on the rail. It's a long shot, -5V tends to be more of a williams/older american PCB thing but it's just something else to check if you're at a dead end...and would explain why most other games work but these ones have no sound.
User avatar
crunchywasp
stompin' an' jumpin'
Posts: 8980
Joined: February 10th, 2012, 2:51 pm
eBay: crunchywasp
Gamertag: crunchywasp
PSN: crunchywasp
Initials: MAK
Location: Fife, Scotland

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby crunchywasp » March 9th, 2013, 5:22 am

Thanks buddy. We've checked the -5v and that wasn't the issue...
meijin wrote:As far as I know both games don't require -5v and also I checked the -5v line on the SG and it works. So this is not the problem.

I'm going to build a pass-through as described above this weekend and give that a shot. Fingers crossed that'll do the trick.
Image
User avatar
crunchywasp
stompin' an' jumpin'
Posts: 8980
Joined: February 10th, 2012, 2:51 pm
eBay: crunchywasp
Gamertag: crunchywasp
PSN: crunchywasp
Initials: MAK
Location: Fife, Scotland

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby crunchywasp » March 23rd, 2013, 10:03 am

Quick update just in case any one else has a similar issue or is remotely interested...

I built a pass-through as described a few posts up and it works grand with Asura Blade but not Sengoku Blade :think:

I'm not entirely sure what's going on with Sengoku Blade :eh: :crazy:
Image
User avatar
SEGASHIRO
Posts: 2
Joined: August 2nd, 2016, 2:11 pm
eBay: butteryummy
Initials: RAD
Location: Toronto, Canada
Contact:

Re: Asura Blade & Sengoku Blade - No audio on supergun

Postby SEGASHIRO » March 18th, 2017, 10:19 pm

I have one these boards and I am not getting audio...I am interested!

Return to “Game Hardware Q&A”



Who is online

Users browsing this forum: No registered users