Naomi + Sega IO 837-13551-92 controller issue

Everything Supergun related
Forum rules
ArcadeOtaku forum introduction & rules
User avatar
Vendest
Posts: 7
Joined: January 29th, 2017, 2:51 pm
Location: Singapore

Naomi + Sega IO 837-13551-92 controller issue

Postby Vendest » February 13th, 2017, 4:55 pm

So that is my first post here aside from the introduction thread.

I was gladly building an interface for Naomi when I realized that the controller wouldn't work when connected to the 60 PIN connector (Digital port) of the IO board.
Switched the controller port to the 26 PIN connector (Analogue) with no improvement but the buttons seem to be recognized within test mode.
After pulling out some Schematics I realized that I may need additional boards such as coin validator / coin meter ....
The JVS IO board itself may not be enough. Any idea on how to proceed further?

P.S: I'd like to avoid using my supergun with a JVS to Jamma IO board. The idea is to have a stand alone interface and enjoy 480p on the TV.

Thanks,

io_naomi_jvs.gif
User avatar
nem
Posts: 723
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby nem » February 14th, 2017, 6:12 pm

Been there done that. You need a jumper cable from pin 1 to pin 3 on the digital connector.
User avatar
Vendest
Posts: 7
Joined: January 29th, 2017, 2:51 pm
Location: Singapore

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby Vendest » February 15th, 2017, 5:05 pm

nem wrote:Been there done that. You need a jumper cable from pin 1 to pin 3 on the digital connector.


You've made my day. Thanks!
EXV pin 1 must be used for "enable"

I'll post a pic of the all-in-one interface once completed.
User avatar
Vendest
Posts: 7
Joined: January 29th, 2017, 2:51 pm
Location: Singapore

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby Vendest » February 19th, 2017, 5:18 pm

Done!

Naomi_1.jpg


Naomi_2.jpg
big10p
Posts: 10
Joined: December 3rd, 2016, 12:28 pm
Location: UK

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby big10p » February 20th, 2017, 11:10 pm

Sorry to hi-jack, temporarily, but I have a related question.

nem wrote:Been there done that. You need a jumper cable from pin 1 to pin 3 on the digital connector.

Do I need to jumper pins 2 and 4 in the same manner, to enable player 2 controls? My cab only uses P1 controls, but I've wired in a button to 2P SERVICE in the hope of being able to use it as a credit button. However, the button isn't even recognized in the input test. I've also tried wiring a button to the coin switch pins, but that didn't work, either.

Thanks.
User avatar
Vendest
Posts: 7
Joined: January 29th, 2017, 2:51 pm
Location: Singapore

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby Vendest » February 21st, 2017, 3:20 pm

Pin 1 & 2 are linked by default as well as for 3 & 4.
Hence a single jumper between 1 & 3 or 2 & 4 should enable both P1 and P2.
It works for me with this IO board

You may want to do a continuity test on those pins.
User avatar
nem
Posts: 723
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby nem » February 21st, 2017, 3:32 pm

big10p wrote:Do I need to jumper pins 2 and 4 in the same manner, to enable player 2 controls? My cab only uses P1 controls, but I've wired in a button to 2P SERVICE in the hope of being able to use it as a credit button. However, the button isn't even recognized in the input test. I've also tried wiring a button to the coin switch pins, but that didn't work, either.

Thanks.


Like Vendest said, pin 1 and pin 3 are enough.

What are you trying to use this on? If it's Naomi, what have you set up as service type in System Assignments in the test menu? Common or individual?
big10p
Posts: 10
Joined: December 3rd, 2016, 12:28 pm
Location: UK

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby big10p » February 21st, 2017, 3:39 pm

nem wrote:
big10p wrote:Do I need to jumper pins 2 and 4 in the same manner, to enable player 2 controls? My cab only uses P1 controls, but I've wired in a button to 2P SERVICE in the hope of being able to use it as a credit button. However, the button isn't even recognized in the input test. I've also tried wiring a button to the coin switch pins, but that didn't work, either.

Thanks.


Like Vendest said, pin 1 and pin 3 are enough.

What are you trying to use this on? If it's Naomi, what have you set up as service type in System Assignments in the test menu? Common or individual?

It's on a dedicated Shootout Pool cab (NAOMI). I did have it set to Individual in System Assignments. Should it be set to Common? I'm just trying to get a credit button I've fitted, working.

Also, why does connecting a button to the coin switch pin not work?
User avatar
nem
Posts: 723
Joined: August 17th, 2008, 6:59 pm
Location: Finland

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby nem » February 21st, 2017, 4:23 pm

big10p wrote:It's on a dedicated Shootout Pool cab (NAOMI). I did have it set to Individual in System Assignments. Should it be set to Common? I'm just trying to get a credit button I've fitted, working.

Also, why does connecting a button to the coin switch pin not work?


There's no reason why it shouldn't work. Try setting it on common and use 1P credit as the input.
big10p
Posts: 10
Joined: December 3rd, 2016, 12:28 pm
Location: UK

Re: Naomi + Sega IO 837-13551-92 controller issue

Postby big10p » February 21st, 2017, 8:20 pm

nem wrote:
big10p wrote:It's on a dedicated Shootout Pool cab (NAOMI). I did have it set to Individual in System Assignments. Should it be set to Common? I'm just trying to get a credit button I've fitted, working.

Also, why does connecting a button to the coin switch pin not work?


There's no reason why it shouldn't work. Try setting it on common and use 1P credit as the input.

OK, I'll give that a try. Thanks.

Return to “SuperGun Q&A”



Who is online

Users browsing this forum: No registered users